Определите что будет напечатано в результате работы следующей программы
Перейти к содержимому

Определите что будет напечатано в результате работы следующей программы

  • автор:

Решу ЕГЭ и Незнайка объединились,

чтобы запустить свои курсы ЕГЭ в Тик-Ток формате. Никаких скучных вебинаров, только залипательный контент!

Готовься к ЕГЭ в Тик-Ток формате

«Незнайка» и «Решу ЕГЭ» запускают свои курсы подготовки. Короткие видео, много практики и нереальная польза!

‘; $pop_rand = mt_rand(1,3); $pop_rand_code = $; echo $pop_rand_code; //> ?—>
Вы отправили работу на проверку эксперту. Укажите номер телефона на него придет СМС

Задание № 12565

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг нач цел s, к s := 110 нц для к от 5 до 12 s : = s - 5 кц вывод s кон
s = 110 FOR к = 5 ТО 12 s = s — 5 NEXT к PRINT s END
var s, k: integer; begin s := 110; for k := 5 to 12 do s : = s - 5; write(s); end.

Решать другие задания по теме: Простейший циклический алгоритм, записанный на алгоритмическом языке
Показать ответ
Комментарий:

Рассмотрим вариант на Паскаль. Т.к. цикл for будет выполняться от k=5 до k=12, он пройдет 8 раз, т.е. тело внутри цикла будет выполнено ровно 8 раз

s := s — 5 повторится 8 раз. Начальное s := 110. Вычитаем: 110-5*8=70

Ответ: 70

Определите, что будет выведено в результате выполнения следующей программы

Рабочая тетрадь по Информатике 9 класс Босова

Задание 78. Определите, что будет выведено в результате выполнения следующей программы. а)


Ответ: 4.5 — среднее значение элементов массива а. б)


Ответ: 4 — количество элементов массива, значения которых больше 10. в) Результат такой, потому что цикл затрагивает только 6 элементов массива (for i:=1 to 6), то есть a[7]=2 он не учитывает в программе. Именно по этому значение m, которое учитывает положительные числа, нашло только два элемента.


Ответ: m = 2 — количество положительных чисел среди первых шести элементов массива; n = 3 — количество отрицательных чисел среди первых шести элементов массива; к = 1 — количество нулей среди первых шести элементов массива. г)


Ответ: d = 4 — номер элемента массива, имеющего наибольшее значение (первого наибольшего, если таких элементов несколько).

of your page —>

  • Правообладателям
  • Карта сайта

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных трём.

Рабочая тетрадь по Информатике 8 класс Босова
of your page —>

Задание 213. Определите, что будет выведено в результате работы следующей программы. Текст программы приведен на двух языках программирования(Алгоритмический язык и паскаль). Алгоритмический язык:
алг
нач

цел s, k
s:=0
нц для k от 1 до 6
s:=s+15
кц
вывод
s
кон Паскаль:
var s, l: integer;
begin
s:=0
for k:=1 to 6 do s:=s+15;
write (s)
end. Ответ: 90
P.S. Цикл 6 раз повторяет одно и тоже действие и прибавляет к изначальному s=0 число 15, получается 90.

of your page —>

  • Правообладателям
  • Карта сайта

Информатика, помогите, пжл. СМ

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический
язык:
алг
нач
цел s, k
s := 0
нц для k от 3 до 8
s := s + 3 * k
кц
вывод s
кон

Бейсик:
DIM s, k AS INTEGER
s = 0
FOR k = 3 TO 8
s = s + 3 * k
NEXT k
PRINT s

Паскаль
Var s, k: integer;
Begin
s := 0;
for k:=3 to 8 do
s := s + 3 * k;
write(s);
End.

Напишите напечатанное и объясните, почему именно оно.

Лучший ответ

Тут же всё написано — идёшь по алгоритму.
s=0+3*3=9
s=9+3*4=21
s=21+3*5=36
s=36+3*6=54
s=54+3*7=75
s=75+3*8=99

Остальные ответы
не понял вопроса
s равно 99
~~ W a V e ~~Ученик (198) 11 лет назад
как вы нашли s?

Павел Курда Мастер (1993) цик работает, пока k не будет равнятся 8, на каждом шаге оно будет увеличиваться на 1 на первом шаге k=3 s=0+3*3=9 на втором шаге k=4 s=9+3*4=21 на третьем шаге k=5 s=21+3*5=36 и так далее, к тому времени как k станет равным 8 s будет ранятся 99. Цикл завершится.

Цикл «for k := 3 to 8 do» выполняется шесть раз. Каждый раз переменная s увеличивается на 6. Поскольку изначально s = 0, после выполнения программы получим: s = 6 · 6 = 36.

Владислава ЮрковаУченик (103) 3 года назад
откуда мы взяли число 6?

Богдан Эминов Профи (686) Владислава Юркова, вообще должно было получиться 99, хз откуда я взял 6. Получается порядок такой: k=3 s=0+3*3=9 k=4 s=9+3*4=21 k=5 s=21+3*5=36 k=6 s=36+3*6=54 k=7 s=54+3*7=75 k=8 s=75+3*8=99

Помогите пожалуйста)
Определите, что будет напечатано в результате работы следующей программы.

англ
нач
цел s, k
s=500
нц для k от 4 до 10
s= s-2*k
кц
вывод s
кон

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *