Как сохранить в xlsb
Перейти к содержимому

Как сохранить в xlsb

  • автор:

Уменьшение размера файла Excel электронных таблиц

Если размер файла слишком велик, попробуйте сделать его более управляемым, следуя советам ниже.

Сохранение таблицы в двоичном формате (XSLB)

Чтобы уменьшить размер файла, можно сохранить таблицу в виде двоичной книги (XSLB), а не формата по умолчанию (XSLX). По умолчанию используется формат XML, что важно при использовании данных в сторонних программах, так как XML является открытым стандартом. Однако в большинстве целей двоичного формата достаточно и он сохраняется в файле меньшего формата.

  1. Перейдите в меню >параметры >Сохранить.
  2. В списке Сохранениефайлов в этом формате в списке Сохранить книги выберите Excel Двоичная книга.

Сохранение в двоичном формате

Этот параметр задает двоичный формат по умолчанию. Если вы хотите сохранить по умолчанию Excel книгу (.xlsx), но сохранить текущий файл как двоичный, выберите параметр в диалоговом окке Сохранить как.

Примечание: Если файл находится в SharePoint, возможно, вы не видите параметр Сохранить как. В этом случае вы можете сохранить копию на локальном диске, сохранить ее как двоичное, а затем заменить исходный файл новым двоичным.

  1. Перейдите в > сохранить как и, если файл сохраняется впервые, выберите расположение.
  2. В списке типов файлов выберите Excel Двоичная книга (XLSB).

Сохранение в Excel двоичной книги

Сохранение таблицы в двоичном формате (XSLB)

Чтобы уменьшить размер файла, можно сохранить таблицу в виде двоичной книги (XSLB), а не формата по умолчанию (XSLX). По умолчанию используется формат XML, что важно при использовании данных в сторонних программах, так как XML является открытым стандартом. Однако в большинстве целей двоичного формата достаточно и он сохраняется в файле меньшего формата.

  1. Перейдите в меню >параметры >Сохранить.
  2. В списке Сохранениефайлов в этом формате в списке Сохранить книги выберите Excel Двоичная книга.

Этот параметр задает двоичный формат по умолчанию.

Если вы хотите сохранить по умолчанию Excel книгу (.xlsx), но сохранить текущий файл как двоичный, выберите параметр в диалоговом окне Сохранить как:

  1. Выберите Файл >Сохранить как.
  2. В списке Тип файла выберите Excel двоичной книги (XLSB).

Уменьшение количества таблиц

Если у вас есть таблицы с данными, которые вы не используете и которые не содержат формул, удалите их из таблицы.

Чем больше точек данных в книге, тем больше размер файла. Если удалить неиспользование данных, размер файла уменьшится.

Сохранение изображений с более низким разрешением

  1. Откройте меню Файл, выберите раздел Параметры, а затем — Дополнительно.
  2. В области Размер и качество изображениясделайте следующее:
    • Выберите Отменить редактирование данных. Этот параметр удаляет хранимые данные, которые используются для восстановления исходного состояния изображения после его изменения. Обратите внимание, что если удалить данные редактирования, восстановить изображение будет нельзя.
    • Убедитесь, что не выбрано сжатие изображений в файле.
    • В списке Разрешение по умолчанию выберите разрешение 150ppi или более низкое. В большинстве случаев разрешение не должно быть выше.

Параметры размера и качества изображения

Сжатие рисунков

  1. Выберите рисунок в документе. На ленте появится вкладка Формат рисунка.
  2. На вкладке Формат рисунка в группе Настройка выберите Сжать рисунки.
  3. В области Параметры сжатиясделайте следующее:
    • Чтобы сжать все рисунки в файле, снимайте снимок Применить только к этому рисунку. Если этот параметр выбран, изменения, внесенные здесь, будут влиять только на выбранный рисунок.
    • Выберите Удалить обрезанные области рисунков. Этот параметр удаляет обрезанные данные рисунка, но вы не сможете их восстановить.
  4. В области Разрешениесделайте следующее:
    • Выберите Использовать разрешение по умолчанию.

Параметры сжатия рисунков

Не сохранения кэша данных с файлом

Если таблица содержит таблицу, можно уменьшить размер файла, не экономя кэш исходных данных в файле, а обновляя кэш данных при его открытие.

  1. Выберите любую ячейку в таблице.
  2. На вкладке Анализ таблицы в группе Таблица выберите Параметры.
  3. В диалоговом окне Параметры таблицы выберите вкладку Данные и сделайте следующее:
  4. Чтобы сохранить исходные данные с файлом, с помощью сохранения исходных данных с помощью сохранения.
  5. Выберите Обновить данные при открытии файла.

Как сохранить в xlsb

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Сохранение книги в другом формате файла

В большинстве случаев вы наверняка будете сохранять свои книги в текущем формате файл (XLSX). Но иногда может потребоваться сохранить книгу в другом формате, например для более ранней версии Excel, в текстовый файл или в файл PDF или XPS. Просто помните, что всякий раз, когда вы сохраняете книгу в другом формате файла, часть его форматирования, данных и функций не может быть сохранены.

Список форматов файлов (также называемых типами файлов), которые вы можете (и не можете) открыть или сохранить в них документы в Excel 2013, см. в разделе Поддерживаемые Excel форматы файлов в конце этой статьи.

Пункт

  1. Откройте книгу, которую вы хотите сохранить.
  2. На вкладке Файл выберите команду Сохранить как.

Выбор варианта расположения

В разделе Места выберите расположение, где нужно сохранить книгу. Например, выберите OneDrive, чтобы сохранить файл в веб-хранилище, или Компьютер, чтобы сохранить файл в локальной папке, такой как Документы.

Диалоговое окно

В диалоговом окне Сохранение документа перейдите в нужное расположение.

Примечание: Список доступных форматов файлов зависит от типа активного листа в книге (лист, лист диаграммы или другой).

Преобразование книги Excel 97—2003 в текущий формат файла

Если вы открыли книгу Excel 97—2003, но вам не нужно хранить ее в этом формате файла, просто преобразуйте книгу в текущий формат файла (XLSX).

  1. В меню Файл выберите команду Сведения.
  2. Нажмите кнопку Преобразовать.

Кнопка

Поддерживаемые Excel форматы файлов

В Excel 2013 вы можете открывать и сохранять файлы проектов в перечисленных ниже форматах.

Форматы файлов Excel

Стандартный формат файлов Excel 2007—2013, основанный на языке XML. В этом формате нельзя сохранять код макросов Microsoft Visual Basic для приложений (VBA) и листы макросов Microsoft Office Excel 4.0 (XLM).

Книга Strict Open XML

Версия ISO Strict формата файла книги Excel (XLSX).

Формат Excel 2007–2013 на основе XML с поддержкой макросов. В этом формате можно сохранять код макросов VBA и листы макросов Excel 4.0 (XLM).

Двоичная книга Excel

Формат двоичных файлов (BIFF12) для Excel 2007—2013.

Стандартный формат файлов Excel 2007—2013 для шаблонов Excel. Не позволяет сохранять код макросов VBA, а также листы макросов Microsoft Excel 4.0 (XLM).

Формат файлов с поддержкой макросов для шаблонов Excel в приложениях Excel 2007—2013. В этом формате можно сохранять код макросов VBA и листы макросов Excel 4.0 (XLM).

Книга Excel 97—2003

Формат двоичных файлов Excel 97 — Excel 2003 (BIFF8).

Шаблон Excel 97- Excel 2003

Формат двоичных файлов Excel 97 — Excel 2003 (BIFF8) для хранения шаблонов Excel.

Книга Microsoft Excel 5.0/95

Формат двоичных файлов Excel 5.0/95 (BIFF5).

Таблица XML 2003

Формат файлов XML-таблиц 2003 (XMLSS).

Данные XML Data

Формат данных XML.

Надстройка Microsoft Excel

Формат файлов надстроек Excel 2007—2013 на основе XML с поддержкой макросов. Надстройка — это программа, обеспечивающая возможность выполнения дополнительного кода. Позволяет использовать проекты VBA и листы макросов Excel 4.0 (XLM).

Надстройка Excel 97—2003

Надстройка Excel 97-2003, дополнительная программа, предназначенная для выполнения дополнительного кода. Поддерживает использование проектов VBA.

Формат файла Excel 4.0, в котором сохраняются только обычные листы, листы диаграмм и макросов. В приложении Excel 2013 можно открыть книгу в этом формате, но сохранить в нем файл Excel нельзя.

Форматы текстовых файлов

Форматированный текст (разделители — пробелы)

Формат для Lotus, с разделителями — пробелами. Сохраняет только активный лист

Текст (разделители — знаки табуляции)

Сохраняет книгу в виде текстового файла, разделенного знаками табуляции, — для использования в другой операционной системе Microsoft Windows — и гарантирует, что символы табуляции, разрывы строк и другие символы будут интерпретироваться правильно. Сохраняет только активный лист.

Сохраняет книгу в виде текстового файла, разделенного знаками табуляции, — для использования в операционной системе Макинтош — и гарантирует, что символы табуляции, разрывы строк и другие символы будут интерпретироваться правильно. Сохраняет только активный лист.

Сохраняет книгу в виде текстового файла, разделенного знаками табуляции, — для использования в операционной системе MS-DOS — и гарантирует, что символы табуляции, разрывы строк и другие символы будут интерпретироваться правильно. Сохраняет только активный лист.

Текст в кодировке Unicode

Сохраняет книгу в виде текста в кодировке Unicode, стандартной кодировке символов, разработанном Unicode Consortium.

CSV (разделители — запятые)

Сохраняет книгу в виде текстового файла, разделенного знаками запятой, — для использования в другой операционной системе Windows — и гарантирует, что символы табуляции, разрывы строк и другие символы будут интерпретироваться правильно. Сохраняет только активный лист.

Сохраняет книгу в виде текстового файла, разделенного знаками запятой, — для использования в операционной системе Макинтош — и гарантирует, что символы табуляции, разрывы строк и другие символы будут интерпретироваться правильно. Сохраняет только активный лист.

Сохраняет книгу в виде текстового файла, разделенного знаками запятой, — для использования в операционной системе MS-DOS — и гарантирует, что символы табуляции, разрывы строк и другие символы будут интерпретироваться правильно. Сохраняет только активный лист.

Формат обмена данными. Сохраняет только активный лист.

Формат Symbolic Link. Сохраняется только активный лист.

Примечание: Если вы сохраните книгу в любом текстовом формате, будут потеряны все элементы форматирования.

Другие форматы файлов

dBase III и IV. Файлы этого формата можно открывать в Microsoft Excel, но сохранять файлы Microsoft Excel в формате dBase нельзя.

Таблица OpenDocument. Файлы приложения Excel 2010 можно сохранять в формате, который позволяет открывать их в редакторах электронных таблиц, поддерживающих формат таблиц OpenDocument, таких как Google Docs или OpenOffice.org Calc. Таблицы в формате ODS также можно открывать в приложении Excel 2010. При сохранении и открытии ODS-файлов может быть потеряно форматирование.

Формат переносимого документа (PDF). Этот формат файла сохраняет форматирование документа и обеспечивает общий доступ к файлам. При просмотре PDF-файла в Интернете и выводе его на печать сохраняется его исходное представление. Данные в файле невозможно изменить. Формат PDF также полезен для документов, которые будут воспроизведены с помощью коммерческих методов печати.

Спецификация XML-бумаги (XPS). Этот формат файла сохраняет форматирование документа и обеспечивает общий доступ к файлам. Когда XPS-файл просматривается в Интернете или печатается, он сохраняет именно тот формат, который вы планировали, и данные в файле не могут быть легко изменены.

Форматы файлов, использующие буфер обмена

Если вы скопировали данные в буфер обмена в одном из следующих форматов файлов, вы можете вставить их в Excel, используя команду Вставка или Специальная вставка (Главная > Буфер обмена > Вставка).

Идентификаторы типа буфера обмена

Рисунки в формате Windows Metafile (WMF) или Windows Enhanced Metafile (EMF).

Примечание: Если вы скопируете метафайл Windows (WMF) из другой программы, Microsoft Excel вставит рисунок в виде расширенного метафайла (EMF).

Рисунки, сохраненные в растровом формате (BMP).

Форматы файлов Microsoft Excel

Двоичные форматы файлов для Excel версий 5.0/95 (BIFF5), Excel 97—2003 (BIFF8) и приложения Excel 2013 (BIFF12).

Формат Symbolic Link.

Формат обмена данными.

Текст (разделители — знаки табуляции)

Текстовый формат со знаками табуляции в качестве разделителей.

CSV (разделители — запятые)

Формат с разделителями-запятыми

Форматированный текст (разделители — пробелы)

RTF. Только из Excel.

GIF, JPG, DOC, XLS или BMP

Объекты Microsoft Excel, объекты правильно зарегистрированных программ, поддерживающих OLE 2.0 (OwnerLink), а также Picture или другой формат презентации.

GIF, JPG, DOC, XLS или BMP

OwnerLink, ObjectLink, Link, Picture или другой формат.

Формат рисованного объекта Office или Picture (EMF)

Отображаемый текст, текст OEM

Веб-страница в одном файле

Веб-страница в одном файле (MHT или MHTML). Этот формат файла объединяет встроенные рисунки, приложения, связанные документы и другие вспомогательные элементы, на которые есть ссылки в документе.

Примечание: Если вы скопируете текст из другой программы, Microsoft Excel вставит этот текст в формате HTML независимо от формата исходного текста.

Форматы файлов, не поддерживаемые в Excel 2013

Указанные ниже форматы файлов больше не поддерживаются, поэтому вы не сможете открыть файлы этих форматов или сохранять файлы в этих форматах.

Для работы с данными книги в программе, которая больше не поддерживается, попробуйте выполнить указанные ниже действия.

  • Найти в Интернете компанию, выпускающую конвертеры файлов для форматов, не поддерживаемых Excel.
  • Сохраните книгу в другом формате файла, который можно открыт в другой программе. Например сохраните книгу в электронную таблицу XML или текстовый формат файла, который может поддерживаться в другой программе.

Идентификаторы типа буфера обмена

Форматы файлов Excel 2.0, 3.0 и 2.x

WK1, FMT, WK2, WK3, FM3, WK4

.WK1, .WK2, .WK3, .WK4, .WKS

Форматы файлов Lotus 1-2-3 (все версии)

Формат файлов Microsoft Works (все версии)

Формат файла DBASE II

Формат файла Quattro Pro для MS-DOS

Quattro Pro 5.0 и 7.0 для Windows.

Книгу Excel 2007 и более поздних версий можно сохранить в формате предыдущих версий Excel, в файле текстового формата, а также в других форматах, таких как файлы PDF и XPS. Обычно сохранение происходит в формате XLSX, но формат файлов, используемый по умолчанию для сохранения, можно изменить. Если вы часто пользуетесь командой Сохранить как, можно добавить ее на панель быстрого доступа.

Сохранение книги Excel в файле другого формата

Важно: При сохранении книги в формате файла Excel другой версии форматирование и возможности, уникальные для Excel 2007 и более поздних версий, будут потеряны. Дополнительные сведения см. в статье Использование Excel с более ранними версиями Excel.

  1. Откройте в Excel книгу, которую вы хотите сохранить в формате, подходящем для использования в другой программе.
  2. На вкладке Файл выберите команду Сохранить как.
  3. Чтобы сохранить книгу в другом месте, укажите диск и расположение в полях с именем папки и путем к файлу.
  4. Примите имя, предложенное в поле Имя файла, или введите новое имя книги.
  5. В раскрывающемся списке Тип файла выберите формат, подходящий для использования в другой программе.

Для прокрутки списка и отображения большего числа форматов используйте стрелки.

Примечание: В зависимости от типа активного листа (лист книги, лист диаграммы или другие типы листов) будут доступны разные форматы файлов для сохранения.

Совет: Дополнительные сведения о сохранении книги в файл формата PDF или XPS см. в статье Сохранение в формате PDF или XPS.

Сохранение файла другого формата в формате Excel 2007 и более поздних версий

Любой файл, который открывается в Excel 2007 и более поздних версий, можно сохранить в текущем формате книги Excel (XSLX). Таким образом вы сможете воспользоваться новыми возможностями, которые не поддерживаются в файлах других форматов.

Примечание: При сохранении книги, созданной в более ранней версии Excel, в формате книги Excel 2007 и более поздних версий некоторые возможности и часть форматирования могут быть потеряны. Сведения о неподдерживаемых функциях Excel 97–2003 см. в статье Использование Excel с более ранними версиями Excel.

  1. Откройте файл, который вы хотите сохранить в формате текущей версии.
  2. На вкладке Файл выберите команду Сохранить как.
  3. Чтобы сохранить файл в другом месте, укажите диск и расположение в полях с именем папки и путем к файлу.
  4. Примите имя, предложенное в поле Имя файла, или введите новое имя книги.
  5. В списке Тип файла выберите один из вариантов:
    • Если книга была создана в более ранней версии Excel и содержит макросы, которые нужно в ней оставить, выберите Книга Excel с поддержкой макросов (*.xlsm).
    • Если вы хотите сохранить книгу как шаблон, выберите Шаблон Excel (*.xltx).
    • Если книга была создана в более ранней версии Excel и содержит макросы, которые нужно в ней оставить, а вы хотите сохранить ее как шаблон, выберите Шаблон Excel с поддержкой макросов (*.xltm).
    • Если вы хотите сохранить книгу в текущем формате книги Excel, выберите Книга Excel (*.xlsx).
    • Если вы хотите сохранить книгу в новом двоичном формате файла, выберите Двоичная книга Excel (*.xlsb).
  6. Нажмите кнопку Сохранить.

Изменение формата файлов, используемого для сохранения по умолчанию

Вы можете изменить тип файла, используемого по умолчанию при сохранении книги.

  1. На вкладке Файл выберите пункт Параметры.
  2. В категории Сохранение в разделе Сохранение книг в поле Сохранять файлы в следующем формате выберите тот формат файла, который вы хотите использовать по умолчанию.

Добавление команды «Сохранить как» на панель быстрого доступа

Команду Сохранить как нельзя вывести на ленту в виде кнопки. Однако вы можете добавить ее на панель быстрого доступа.

Стрелка на панели быстрого доступа

    Щелкните стрелку раскрывающегося списка на панели быстрого доступа и выберите Другие команды.

Книгу Microsoft Office Excel 2007 можно сохранить в файле другого формата. Вы можете сохранить ее в формате предыдущих версий, в формате текстового файла, а также в других форматах, таких как файлы PDF и XPS. Любой файл, который открывается в Office Excel 2007, можно сохранить в формате книги Excel 2007. Excel 2007 по умолчанию сохраняет файлы в формате XLSX, но вы можете изменить формат, используемый для сохранения по умолчанию.

Если вы часто пользуетесь командой Сохранить как, можно добавить ее на панель быстрого доступа.

Сохранение файла в формате Excel 2007

Любой файл, который открывается в Excel 2007, можно сохранить в текущем формате книги Excel (*.xlsx). Таким образом вы сможете воспользоваться новыми возможностями Excel 2007, которые не поддерживаются в файлах других форматов, например сможете увеличивать размер ячеек.

Примечание: При сохранении книги, созданной в более ранней версии Excel, в формате книги Excel 2007 некоторые возможности и часть форматирования могут быть потеряны.

  1. Откройте книгу, которую вы хотите сохранить в формате книги Excel 2007.
  2. Нажмите кнопку Microsoft Office
  • Если книга была создана в более ранней версии Excel и содержит макросы, которые нужно в ней оставить, выберите формат XLSM.
  • Если вы хотите сохранить книгу как шаблон, выберите формат XLTX.
  • Если книга была создана в более ранней версии Excel и содержит макросы, которые нужно в ней оставить, а вы хотите сохранить ее как шаблон, выберите формат XLTM.
  • Если вы хотите сохранить книгу в текущем формате книги Excel, выберите формат XLSX.
  • Если вы хотите сохранить книгу в новом двоичном формате файла, выберите формат XLSB.
  • Дополнительные сведения о форматах файлов см. в статье Поддерживаемые Excel форматы файлов.

Изменение формата файлов, используемого для сохранения по умолчанию

Вы можете изменить тип файла, используемого по умолчанию при сохранении книги.

    Нажмите кнопку Microsoft Office

Добавление команды «Сохранить как» на панель быстрого доступа

Команда Сохранить как недоступна в виде кнопки на ленте Пользовательский интерфейс Microsoft Office Fluent. Однако вы можете добавить ее на панель быстрого доступа.

    Нажмите кнопку Microsoft Office

XLSX против XLSB — Как уменьшить размер файла Excel?

Xlsx и xlsb являются двумя популярными форматами электронных таблиц от Microsoft Excel для хранения больших объемов данных в рабочих книгах. Однако наличие формул, пользовательских данных и объектов (таких как формы) в этих файлах может значительно увеличить размер файла, который может повлиять на производительность загрузки и сохранения этих файлов. Кроме того, большие файлы потребляют значительный объем хранения почтовых ящиков при отправке по электронной почте. В этой статье сравнивается форматы файлов XLSX и XLSB и описывает, как уменьшить размер файлов Excel для загрузки и сохранения рабочих книг намного быстрее.

Xlsx vs xlsb Форматы файлов #

Формат файла XLSX-это тип файлов современной эпохи Microsoft Excel для работы с рабочими книгами. Он был введен в Microsoft Excel 2007+ и является форматом файла по умолчанию для сохранения рабочих книг Excel. Файлы XLSX сохраняются в виде сжатых ZIP -архивов и основаны на комбинации нескольких файлов XML. Файлы XLSB были также введены с Microsoft Excel 2007+ и сохраняются в ZIP контейнере. Однако, в отличие от XLSX и XLSM, это сжатые бинарные компоненты, кодируемые в запатентованном формате.

В чем разница между XLSX и XLSB?

Итак, в чем разница между XLSX и XLSB? Ну, есть несколько различий, которые делают эти два формата файла отличаться друг от друга. В первую очередь они дифференцированы на основе формата файла, скорости, размера файла и загрузки/сохранения.

XLSX XLSB
Saved as a compressed archive with XML-based content inside. Saved as a compressed archive with binary encoded content inside.
XLSX files take larger space on the disc for an Excel workbook. XLSB uses considerably less space for saving the same workbook. It has been found to take 2/3rd of space as compared to the same XLSX file.
XLSX files are encoded/decoded as XML files to be saved/loaded from disc. Saving plain text files takes more time and affects the loading/saving of such files. XLSB files are saved as plain binary encoded compressed data which takes less time to save and load. On average, XLSB takes 4 times shorter than the same size XLSX file.

Хорошо, если XLSB так хорош, почему все не используют XLSB, а не XLSX?

Итак, если XLSB настолько выгодна, почему не все используют его в качестве формата файла по умолчанию для сохранения книг? Что ж, есть некоторые недостатки в использовании файлов XLSB по сравнению с преимуществами, которые он предлагает. И по этим причинам это не формат файла по умолчанию для сохранения рабочих книг.

  • Отсутствие совместимости — XLSB — это двоичный формат файла, и его нельзя использовать в сторонних инструментах, таких как OpenOffice. Более того, большинство сторонних API не смогут работать с файлами XLSB из-за отсутствия внутренних деталей.
  • Совместимость — XLSB не поддерживается более ранними версиями Excel, которые были доступны до Excel 2007. По этой причине файлы XLSB не могут быть открыты в более старых версиях Excel.
  • Security — файлы VBA не дают никаких указаний о наличии макросов в нем, в отличие от форматов файлов XLSX и XLSM. Это может привести к вопросам безопасности

Заключение #

Файлы XLSB меньше, эффективны для открытия и сохранения, а также эффективно хранение по сравнению с популярными файлами XLSX и XLSM. Тем не менее, большинство современных приложений для открытия файлов электронных таблиц работают лучше с файлами XLSX на основе открытых спецификаций, а не с файлами XLSB. По этой причине XLSX остается форматом файла по умолчанию в Excel.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *