Как продлить таблицу в excel
Перейти к содержимому

Как продлить таблицу в excel

  • автор:

Как строить таблицы в Excel

В этой статье мы затронем самые частые темы, которые встречаются при работе с таблицами excel. Мы рассмотрим, как нарисовать таблицу в excel, как транспонировать (перевернуть) таблицу в excel, покажем, как сортировать таблицу в excel, а также как продлить, отформатировать и напечатать.

Работа в Microsoft Excel во многом состоит из построения, оформления и вычисление таблиц.

Практически каждый, кто открывает Excel сталкивается с задачами создания, оформления, преобразования, сортировки и печати таблиц.

В этой статье мы затронем самые частые темы, которые встречаются при работе с таблицами excel. Мы рассмотрим, как нарисовать таблицу в excel, как транспонировать (перевернуть) таблицу в excel, покажем, как сортировать таблицу в excel, а также как продлить, отформатировать и напечатать.

Как нарисовать таблицу в эксель

Нарисовать таблицу в экселе можно многими способами, мы рассмотрим самые простые:

Воспользоваться сеткой.

Т.е. на вкладке «Главная», открыть «Границы» и выбрать пункт «Нарисовать сетку». После этого курсор примет изображение карандаша. Этим карандашом Вы можете вести по диагонали превращая обычные ячейки в таблицу.

как начертить таблицу в excel

Применить все границы.

Если в Вашей таблице уже заполнены данные, то можно сделать просто обрамление таблицы excel границами.

Для этого выделите диапазон Вашей таблицы, потом зайдите на вкладке «Главная» в «Границы» и там выберете «Все границы»:

как строить таблицы в экселе

Как отформатировать таблицу.

Пожалуй, самый эффектный способ оформить таблицу в excel – это сделать форматирование таблицы.

Для этого нужно поместить курсор в любое место Вашей таблицы и на вкладке «Главная» выбрать «Форматировать как таблицу», далее применить любую из готовых цветовых схем:

Как отформатировать таблицу в excel

Таким образом меняется не только форматирование, создается так называемая «умная таблица». Такую таблицу очень удобно продолжить вниз или растянуть.

Как продолжить таблицу в эксель вниз.

Проще всего в экселе продолжить таблицу вниз, если включен режим таблицы. Часто этот режим называют «умной таблицей». Этот режим включается горячими клавишами Ctrl+T или нажатием значка «Таблица» на вкладке «вставка». Ещё один способ описан в предыдущем пункте «Отформатировать таблицу». После включения умной таблицы продлить таблицу в excel можно просто начав заполнять первую строку под ней. Заполнение любой ячейки позволит в экселе продлить таблицу вниз. Теперь Вы знаете, как продолжить таблицу в excel самым простым способом.

Как в excel продлить таблицу вниз

Как растянуть таблицу в excel.

Аналогично в excel можно растянуть таблицу вправо. Для этого нужно заполнить заголовок первого столбца справа от таблицы.

Как растянуть таблицу в эксель

Как отменить умную таблицу в excel.

Все возможности умной таблицы мы обязательно разберем отдельной статьей, здесь мы расскажем, как отменить умную таблицу в excel.

Для этого на любом месте сводной таблицы нужно будет нажать правой клавишей мыши, зайти в раздет «Таблица», а там выбрать «Преобразовать в диапазон».

Как перевернуть таблицу в excel.

В этом разделе мы выясним можно ли в экселе перевернуть таблицу.

Чтобы в экселе перевернуть таблицу горизонтально, нужно сначала выделить и скопировать ту таблицу, которую нужно перевернуть, а затем воспользоваться функцией транспонирование таблицы.

Для этого нужно выделить ячейку в которую нужно перевернуть таблицу горизонтально, нажать на «Правую клавишу мыши», выбрать «Специальная вставка», в правом нижнем углу диалогового окна специальной вставки отметить флажок «Транспонировать», нажать «Ok».

Таким образом в пару кликов можно развернуть таблицу в excel на 90 градусов.

Как в экселе транспонировать таблицу.

Как сортировать таблицу в excel.

Чтобы отсортировать таблицу в excel по возрастанию достаточно поместить курсор внутрь столбца по которому требуется упорядочить таблицу в excel, и на вкладке «Данные» в разделе «Сортировка и фильтры» выбрать порядок сортировки:

  • отсортировать таблицу в excel по возрастанию
  • отсортировать таблицу в excel по убыванию

Как добавить или удалить строку или столбец в таблице

После создания таблицы Excel на листе можно легко добавлять и удалять строки и столбцы.

Чтобы добавить строки и столбцы в таблицу Excel, можно воспользоваться командой Размер таблицы.

Использование команды

  1. Щелкните в любом месте таблицы, чтобы отобразить вкладку Работа с таблицами.
  2. Выберите Конструктор >Размер таблицы.

Изменение размера таблицы

Выделите весь диапазон ячеек, который нужно включить в таблицу, начиная с верхней левой ячейки. В приведенном ниже примере исходная таблица охватывает диапазон A1:C5. После изменения размера с добавлением двух столбцов и трех строк таблица будет включать в себя диапазон A1:E8.

Совет: Вы также можете нажать кнопку Свернуть диалоговое окно

, чтобы временно скрыть диалоговое окно Изменение размера таблицы , выбрать диапазон на листе, а затем нажать кнопку Развернуть диалоговое окно

Другие способы добавления строк и столбцов

Чтобы добавить строку или столбец в таблицу, введите данные в ячейку, расположенную под последней строкой или справа от последнего столбца, вставьте скопированное значение в ячейку или добавьте новые строки или столбцы между существующими.

Ввод данных

  • Чтобы добавить строку внизу таблицы, начните вводить текст в ячейке под последней строкой. Таблица расширится, и в нее будет включена новая строка. Чтобы добавить столбец справа от таблицы, начните вводить текст в ячейку справа от последнего столбца.

В приведенном ниже примере добавления строки при вводе значения в ячейку A4 таблица расширяется за счет нее, а также смежной ячейки в столбце B.

Добавление строки путем ввода данных в первой строке под таблицей

В приведенном ниже примере добавления столбца при вводе значения в ячейку C2 таблица расширяется за счет столбца C. Ему присваивается имя «Кв3», так как Excel выявляет закономерность присвоения имен по заголовкам «Кв1» и «Кв2».

Добавление столбца путем ввода значения в ячейку справа от таблицы

Вставка данных

  • Чтобы добавить строку таким способом, вставьте данные в крайнюю левую ячейку под последней строкой таблицы. Чтобы добавить столбец, вставьте данные в ячейку справа от крайнего правого столбца таблицы.

Если данные, вставляемые в новую строку, содержат столько же или меньше столбцов, чем таблица, она расширяется и включает все ячейки в вставленном диапазоне. Если вставляемые данные содержат больше столбцов, чем таблица, то дополнительные столбцы не становятся частью таблицы. Для их включения необходимо использовать команду Изменить размер.

В приведенном ниже примере добавления строк при вставке значений из диапазона A10:B12 в первую строку под таблицей (строка 5) она расширяется за счет вставленных данных.

Расширение таблицы при вставке данных под ее последней строкой

В приведенном ниже примере добавления столбцов при вставке значений из диапазона C7:C9 в первый столбец справа от таблицы (столбец C) она расширяется за счет вставленных данных, а столбцу присваивается заголовок «Кв3».

Расширение таблицы и добавление заголовка при вставке данных в столбцы

Добавление строки с помощью команды «Вставить»

  1. Чтобы вставить строку, выберите ячейку или строку (но не строку заголовков) и щелкните ее правой кнопкой мыши. Чтобы вставить столбец, выберите любую ячейку в таблице и щелкните ее правой кнопкой мыши.
  2. Наведите указатель мыши на пункт Вставить и выберите команду Строки таблицы выше или Столбцы таблицы слева, чтобы вставить новую строку или столбец соответственно.

Если активна ячейка в последней строке, можно выбрать команду Строки таблицы выше или Строки таблицы ниже.

В приведенном ниже примере новая строка будет вставлена над строкой 3.

Вставка строк таблицы выше

При добавлении столбцов, если выделена ячейка в крайнем правом столбце таблицы, можно выбрать команду Столбцы таблицы слева или Столбцы таблицы справа.

В приведенном ниже примере новый столбец будет вставлен слева от столбца 1.

Добавление столбца таблицы

Удаление строк и столбцов таблицы

  1. Выделите строки или столбцы таблицы, которые требуется удалить. Можно просто выделить одну или несколько ячеек в строках или столбцах таблицы, которые требуется удалить.
  2. На вкладке Главная в группе Ячейки, щелкните стрелку рядом с кнопкой Удалить, а затем выберите команду Удалить строки таблицы или Удалить столбцы таблицы.

Удаление одинаковых строк из таблицы

Дубликаты удаляются из таблицы также легко, как и из любых выбранных данных в приложении Excel.

  1. Щелкните любое место таблицы. Откроется окно Работа с таблицами и вкладка Конструктор.
  2. На вкладке Конструктор в группе Сервис выберите команду Удалить дубликаты.

Примечание: Дубликаты удаляются с листа. Если вы случайно удалили данные, которые вы намеревались сохранить, можно использовать клавиши CTRL+Z или нажать кнопку Отменить

на панели быстрого доступа , чтобы восстановить удаленные данные. Вы также можете использовать условное форматирование для выделения повторяющихся значений, прежде чем удалять их. Дополнительные сведения см. в статье Добавление, изменение и отмена условного форматирования.

Удаление пустых строк из таблицы

  1. Убедитесь, что активная ячейка находится в столбце таблицы.
  2. Щелкните стрелку

Примечание: Флажок (Пустые ячейки) можно установить только в случае, если диапазон ячеек или столбец таблицы содержит хотя бы одну пустую ячейку.

Таким же образом можно отфильтровать и удалить пустые строки. Дополнительные сведения о том, как отфильтровать пустые строки на листе, см. в статье Фильтрация данных в диапазоне или таблице.

  1. Выберите таблицу, а затем выберите Конструктор таблиц > Изменить размер таблицы.
  2. При необходимости измените диапазон ячеек, содержащихся в таблице, а затем нажмите кнопку ОК.

Изменение размера диалогового окна

Важно: Заголовки таблицы не могут перемещаться в другую строку, и новый диапазон должен перекрывать исходный диапазон.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

См. также

Facebook

LinkedIn

Электронная почта

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Как продлить таблицу в excel

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Как использовать вычисляемые столбцы в таблице Excel

Вычисляемые столбцы в таблицах Excel упрощают ввод формул. Формула, введенная в одну ячейку столбца, автоматически распространяется на его остальную часть. При этом не приходится использовать заполнение или копирование. Это позволяет сэкономить время, особенно при наличии множества строк. То же самое происходит при изменении формулы: изменение также распространяется на все остальные ячейки вычисляемого столбца.

Примечание: Снимки экрана в этой статье получены в Excel 2016. Если вы используете другую версию, интерфейс может немного отличаться, но функции будут такими же.

Создание вычисляемого столбца

Добавление нового столбца путем ввода данных в пустой столбец справа от существующей таблицы

  1. Создайте таблицу. Если вы не знакомы с таблицами Excel, см. статью Общие сведения о таблицах Excel.
  2. Вставьте в таблицу новый столбец. Введите данные в столбец справа от таблицы, и Excel автоматически расширит ее. В этом примере мы создали новый столбец, введя «Итог» в ячейке D1.

Чтобы добавить столбец, на вкладке

Советы:

  • Вы также можете добавить столбец на вкладке Главная. Просто щелкните стрелку на кнопке Вставить и выберите команду Вставить столбцы таблицы слева.

Добавление формулы в ячейку таблицы, которая будет автоматически заполнена в других ячейках для создания вычисляемого столбца

Введите нужную формулу и нажмите клавишу ВВОД.

Пример формулы, которая использовалась для создания вычисляемого столбца в таблице

В этом случае мы ввели =СУММ(, а затем выбрали столбцы Кв1 и Кв2. В результате Excel создал следующую формулу: =СУММ(Таблица1[@[Кв1]:[Кв2]]). Такие формулы называются формулами со структурированными ссылками, и их можно использовать только в таблицах Excel. Структурированные ссылки позволяют использовать одну и ту же формулу в каждой строке. Обычная формула Excel выглядела бы как =СУММ(B2:C2), и ее было бы необходимо добавить в остальные ячейки путем копирования и вставки или заполнения. Дополнительные сведения о структурированных ссылках см. в статье Использование структурированных ссылок в таблицах Excel.
При нажатии клавиши ВВОД формула будет автоматически применена ко всем ячейкам столбца, которые находятся сверху и снизу от активной ячейки. Для каждой строки используется одна и та же формула, но поскольку это структурированная ссылка, Excel знает, на что она ссылается в каждой строке.

Команда для перезаписи существующих формул в вычисляемом столбце, когда одна формула отличается от остальных

  • При копировании формулы во все ячейки пустого столбца или заполнении его формулой он также становится вычисляемым.
  • Если ввести или переместить формулу в столбец, уже содержащий данные, это не приведет к автоматическому созданию вычисляемого столбца. Однако отобразится кнопка Параметры автозамены, с помощью которой можно перезаписать данные и создать вычисляемый столбец.

Команда для отмены вычисляемого столбца после ввода формулы

При вводе новой формулы, которая отличается от существующих в вычисляемом столбце, она будет автоматически применена к столбцу. Вы можете отменить обновление и оставить только одну новую формулу, используя кнопку Параметры автозамены. Обычно не рекомендуется этого делать, так как столбец может прекратить автоматически обновляться из-за того, что при добавлении новых строк будет неясно, какую формулу нужно к ним применять.

Создание исключений для вычисляемого столбца

В вычисляемый столбец можно включать формулы, отличающиеся от формулы столбца. Ячейки с такими формулами становятся исключениями и выделяются в таблице. Это позволяет выявлять и устранять несоответствия, возникшие по ошибке.

Уведомление о несогласованной формуле в таблице Excel

Примечание: Исключения вычисляемого столбца возникают в результате следующих операций.

  • При вводе в ячейку вычисляемого столбца данных, отличных от формулы.
  • Ввод формулы в ячейку вычисляемого столбца и нажатие кнопки Отменить

Примечание: Если скопированные данные содержат формулу, она заменяет данные в вычисляемом столбце.
Примечание: В этом случае исключение не помечается.

Уведомление об ошибке отображается только в том случае, если включена фоновая проверка ошибок. Если вы не видите сообщение об ошибке, откройте Файл > Параметры > Формулы и убедитесь, что флажок Включить фоновую проверку ошибок установлен.

Кнопка Office 2007

    Если вы используете Excel 2007, нажмите кнопку Office

Прекращение создания вычисляемых столбцов

Параметр автоматического заполнения формул для создания вычисляемых столбцов в таблице Excel по умолчанию включен. Если не нужно, чтобы приложение Excel создавало вычисляемые столбцы при вводе формул в столбцы таблицы, можно выключить параметр заполнения формул. Если вы не хотите выключать этот параметр, но не всегда при работе с таблицей хотите создавать вычисляемые столбцы, в этом случае можно прекратить автоматическое создание вычисляемых столбцов.

Кнопка Office 2007

    Включение и выключение вычисляемых столбцов
    На вкладке Файл нажмите кнопку Параметры. Если вы используете Excel 2007, нажмите кнопку Office

и выберите Параметры Excel.

  • Выберите категорию Правописание.
  • В разделе Параметры автозамены нажмите кнопку Параметры автозамены
  • Откройте вкладку Автоформат при вводе.
  • В разделе Автоматически в ходе работы установите или снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы включить или выключить этот параметр.

    Совет: Вы можете также щелкнуть кнопку Параметры автозамены, которая отобразится в столбце таблицы после ввода формулы. Нажмите кнопку Параметры автозамены, а затем снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы отключить этот параметр.

    Если вы используете Mac, выберите Excel в главном меню, а затем щелкните Параметры > Формулы и списки > Таблицы и фильтры > Автоматически заполнять формулы.

    Вычисление значений в сводной таблице

    Вы также можете создавать настраиваемые вычисляемые поля со сводными таблицами, где создается одна формула, а Затем Excel применяет ее ко всему столбцу. Дополнительные сведения о вычислении значений в сводной таблице.

    Дополнительные сведения

    Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

  • Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *